Window下ExMobi工程环境部署

此课程旨在帮助工程人员和服务端管理人员在windows环境下如何安装升级卸载ExMobi,以及对ExMobi服务端的配置说明。

课件下载

开始学习并下载课件
课程小节

  • 全新安装

    全新安装包括第三方软件的安装和ExMobi-server的安装。ExMobi-server从5.6.2版本开始,增加了对64位的Windows操作系统的支持,正确安装后,在64位环境下,ExMobi不再是操作系统兼容的32位进程,而是真正的64位进程。

  • 升级(手动升级)

    升级前,需首先关闭ExMobi服务,进入Windows服务管理。查找到Apache Tomcat tomcat_exmobi服务,手动关闭Exmobi服务,另外需要注意的是数据库的备份和程序备份。

  • 升级(脚本自动)

    升级前,需首先关闭ExMobi服务,进入Windows服务管理。查找到Apache Tomcat tomcat_exmobi服务,手动关闭Exmobi服务,注意备份数据库和程序

  • 配置

    ExMobi-4.4.0以上的版本,支持纯界面配置,安装完成后,输入http://ip:8001/manager完成相关配置

培训建议

在掌握windows环境下安装部署exmobi,首先需要熟练windows操作系统相关操作,在学习之前先准备好windows service2003或是service2008ExMobiwindows版本的安装包exmobi-x.x.x.x.zip,和最新的第三方软件ExMobi-thirdsoft-1.0-win .zip。非烽火内部人员可以通过地址http://www.exmobi.cn/product/version.html 获取相关安装包。准备好后需要自己亲自的体验安装过程。

知识体系

准备安装所需环境,以及安装包并安装

网络资源准备

需根据项目实际安装的组件,调整防火墙,开放相应的端口:

服务名称

端口号

备注

SSH

22

TCP协议

Web/client

8001

TCP协议

Web/client SSl

8443

TCP协议

PNS

18001

若基座使用的是4.6以下的版本,采用UDP协议,需开通此端口

8002

若基座使用4.6以上的版本,采用TCP协议,需开通此端口

软硬件资源准备

硬件配置要求

内存不低于2G,磁盘不低于50G(最低配置)

目前所支持的操作系统

Server 20032008

服务端要求

ExMobi-SERVER-4.4.0版本以上

第三方软件要求

Exmobi-thirdsoft-1.0-win.Zip

获取地址:http://www.exmobi.cn/product/third.html

基座要求

最新应用插件差异升级功能需要基座4.5.0.0及以上;若想使用tcpPNS,需使用4.6.0.0以上的版本; 其他兼容

上传license,查看节点注册状态,和页面打开情况是否正常,并查看日志打印是否有报错

ExMobi5.6.2以后没有自带的试用license,所以需要安装好后,申请相应版本的license上传。上传好后检查节点状态是否已经注册,并查看后台日志是否有报错。

升级卸载exmobi

5.9之前的exmobi只能采用手动升级的,5.9以后版本,可以根据情况选择一键升级,和手动升级。注意升级之前做好备份。卸载之前请关闭服务。难点在于数据库不在本地升级。

课程信息

  •   课程难度: 初级
  •   课程时长: 100分钟
  •   学习人数: 137
未学习

前置课程